Эфириум

Nethermind исправила критическую ошибку в Ethereum-клиенте

Компания-разработчик Nethermind исправила критический баг в клиенте исполнения Ethereum, который вызывал сбой при обработке блоков валидаторами.

По словам технического содиректора фирмы Дэниеля Каделы, ошибка консенсуса затронула версии ПО с 1.23 по 1.25. Всем операторам узлов необходимо обновиться до релиза 1.25.2.

We have the fix!
Please update to 1.25.2
No resync is needed.https://t.co/fV3MEdipVX…
Versions up to 1.22 don’t have that bug, only 1.23-1.25 are affected.

— DanielC (@_D4nie1_) January 21, 2024

Первым об ошибке сообщил пользователь GitHub под ником wga22. Он заявил, что в клиенте исполнения Nethermind возникала ошибка при проверке транзакций.

Хотя инцидент затронул малую часть узлов Ethereum, он привел к возобновлению дискуссии касательно зависимости сети от крупных клиентов вроде Geth.

Today’s beacon chain hiccup has once again highlighted the importance of EL client diversity.

This could have been a very different outcome if the bug was caused by Geth, which is currently a supermajority.

Switch to a minority client, and help keep Ethereum secure! pic.twitter.com/NkK8HOw5uB

— liam 📜 (@daddysether) January 21, 2024

«Сегодняшний сбой в Beacon Chain еще раз подчеркнул важность разнообразия клиентов Ethereum. Результат мог бы быть совсем другим, если ошибка находилась в Geth, который в настоящее время составляет подавляющее большинство. Переходите на клиенты меньшинства и помогите обеспечить безопасность Ethereum», — заявил пользователь под ником daddysether.

В настоящее время ПО Geth используют 84% валидаторов Ethereum, а Nethermind — лишь 8,2%. Сторонники децентрализации утверждают, что такой уровень концентрации нод на одном клиенте создает высокую угрозу для блокчейна.

Timely and friendly reminder to get tf off Geth.

Nothing against Geth (they’re great) but you’re taking on disproportionate risk by running it. pic.twitter.com/CxCNfmuEKU

— Marceau 🏝️ (@marceaueth) January 21, 2024

«Своевременное и дружеское напоминание о том, что пора избавиться от Geth. Ничего не имею против этого клиента (он великолепен), но вы берете на себя непропорциональный риск, запуская его», — написал marceaueth.

Напомним, 25 декабря 2023 года L2-решение zkSync Era временно остановило производство блоков из-за непредвиденной ошибки. Разработчики сообщили, что сбой был вызван багом на одном из серверов, в результате чего сработали протоколы безопасности.

Ранее сеть второго уровня Arbitrum One перестала обрабатывать транзакции из-за значительного увеличения сетевого трафика. Работоспособность сети удалось восстановить менее чем за два часа.

Источник

Click to rate this post!
[Total: 0 Average: 0]
Show More